2

I am using the ckeditor for drupal and the video plugin for it to embed video's to site. I have tried to edit the Video plugin javascript file like below so it will spit out something like this <source scr="" type=""> but have had no luck.

innerHtml = '<cke:source src="'+video.src+'" type="'+video.type+'">';

However once I go to click okay ckeditor or drupal adds a closing slash at the end of the source tag to make it look like this:

<source scr="" type="" />

I have turned off "Correct faulty and chopped off HTML" and it still adds it at the end.

Even when viewing source view of the content editor there is /> present.

Is it ckeditor or drupal adding this at the end of source tags and how can I remove it?

Using CKEditor 7.x-1.16 Video Plugin for ckeditor

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.