1

I'm using the modules Migrate and Drupal to Drupal Migration. And I'm just using the UI of the migrate_d2d-module to migrate some content of a D7 site to another D7 site.

It works very well for users and there pictures, and the nodes are migrated too with the fields: title, author, date, body etc. BUT not with the image field! That means the images of the nodes are missing. :-/

How can I solve this? I'm sure I have to do some kind of mapping?

What data I have to use for this:

[field_product_image:destination_dir]
[field_product_image:destination_file]
[field_product_image:source_dir]

The image field is field_product_image and I have exported/imported the content type of the nodes to my new D7 installation. the Images are stored in default/files/image/galerien.

Thanks for helping me!

  • Did you migrated the files first? – Sumit Madan Apr 8 '15 at 8:13
  • no i just went through the wizard (m_d2d UI) and there i choosed all content what i want to migrate. It said"migrate files other than userpics" and i checked this option. At the end it migrates all data together. – lolhonk Apr 8 '15 at 8:20
  • Try reverting it again and migrate step by step. First files then roles, users, nodes in sequences. – Sumit Madan Apr 8 '15 at 8:22
  • Sadly i have the same problems. I migrate all files first and then migrate the nodes but still same problem: image-field is missing. For the userimages it works well but not for the images of the nodes – lolhonk Apr 8 '15 at 8:34
  • Oh yeah. Can I see your mapping of image field? I know what can be the issue. – Sumit Madan Apr 8 '15 at 8:37
0

Thanks very much Sumit Madan,

he gives me the solution:

Mapping:

for the file class of the image field enter this as "standard value": MigrateFileFid

set "TRUE" for preserve_files of your image-field.

thanks again!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.