2

Is it possible to disable the Ajax from the exposed form filter only and not the whole view action [sorting - paging] !?

1
  • Why would you do that? Please provide more information.
    – leymannx
    Apr 8 '15 at 14:37
1

You can use better exposed filter module for this Set Use AJAX to Yes under Advanced -> other section Set Exposed form style to Better Exposed Filters and keep auto submit option disabled in BEF Settings.

1
  • I was doing exactly this, but there was prompt error caused by Ajax sent when i click inside any input in the exposed form then hit enter i recognized an Ajax sent in the firebug while the page reload, the reloading itself should not happen i know, but that because i doubled the form reset & submit buttons which is wrong i know but there was no other way based on the request & the design, anyway i disabled the Ajax at all based on what is more priority double form buttons or Ajax feature. Apr 9 '15 at 9:19
1

If you can use js then this code will help you

$("<filter field Id>" ).change(function() {    
        event.preventDefault();
        $( "<filter form id>" ).submit();
    }); 

Not the answer you're looking for? Browse other questions tagged or ask your own question.