3

I tried to configure Drupal 7.36 with WAMP and result back with the below error after clicking "configure site". I am using Window7. Please help!

Fatal error: Call to undefined function field_attach_load() in C:\wamp\www\sdg\includes\entity.inc on line 320

  • Was this an upgrade or installing from scratch? If you know how; please check the number of tables in your database. It's possible something went wrong and installation never completed. – Weston Wedding Apr 10 '15 at 15:54
  • Please take a look here: drupal.org/node/2128461 Never used it myself, just a quick google result :-) – Guardian Apr 10 '15 at 15:57
1

It looks like this issue has cropped up because of a myriad of potential causes, and some have been fixed while others have not.

The first step, assuming this is an installation from scratch, would be to empty your database and try again. I've had the initial install go wrong once and just trying again went fine.

There is an extensive list of fixes at https://www.drupal.org/node/481758. In the unlikely case of Drupal's issue queue going away, here is the main text. I'd recommend going to the link and reading through the (extensive) comments to see if specifics match your situation.

In certain circumstances, the following error (or something similar) may be displayed during the installation process:

Fatal error: Call to undefined function field_attach_load() in ~\modules\user\user.module on line 270

This error seems to be caused by a problem during the Drupal system installation, causes installation to fail after only creating 31 database tables, and will make requests to the front page of the site display a 'Page not found' error. This seems to happen as a result of various different configuration problems, browser issues, etc. Some of the things you should try to change before throwing your hands up in frustration:

7: Make sure you're not reaching the configured max_execution_time for PHP is not being reached.

25: Switch back to the default php.ini, restart Apache, and see if install works.

27: Make sure dependencies[] = field is defined in your install profile's .info file.

34: Using a different browser (e.g. use Chrome instead of Safari) during installation may help.

36: Switching the bundled jQuery to version 1.7.1 might fix the problem, at least for Safari users.

37, 42, 54: Dropping the entire database and installing again might fix the problem.

45, 141: Limiting the database name length to < 8 characters may fix the problem.

57: Make sure the database user Drupal is using has all permissions for the database (GRANT ALL ON [db]).

59: Make sure your browser's cookies are enabled when performing an installation.

61: Restarting php-fpm fixed the problem.

66: Setting the $cookie_domain variable in settings.php fixed the problem.

82: The problem could be related to install.php not loading field.attach.inc at whatever bootstrap level it is running at.

88: Make sure the $base_url variable in settings.php is correct.

92: Ensuring the database name had only lowercase ASCII characters fixed the problem.

108: Make sure your Apache configuration doesn't do anything that might cause cookies to be dropped.

135: If it's an install in an existing Drupal directory, temporarily move all the modules in sites/all/modules out of the Drupal tree while installing.

137: Disable the php opcache module before proceeding with installation As you can see, there are a TON of different things that can cause this issue. The root cause is installation fails during module installation, and won't ever continue past that point until the database is dropped and recreated again.

1

SAme error on a xampp installation.

Solved setting the collation of the DB to utf8_general_ci.

0

Solved setting the collation of the DB to utf8_general_ci.

And before that drop all tables from data base, because in new base I see some tables, not all needed tables, that drupal created before fail. And it fail and fail if I set utf8_general_ci and not delete that tables.

  • of course, i mean, set the colaltion to uft8_general_ci on the newly created DB. I suppose it was obvius considering that the error is raised in the drupal installation process. – alexroat Jul 26 '17 at 15:32
  • Yes, I make new DB and new drupal installation. I run install and it fail. I change collation and rerun installation and it also fail, because my new BD was not empty, drupal make some tables on installation process run (not all), and it fail until I not delete all tables (from my what I think new empty table). – Michael Jul 27 '17 at 6:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.