3

I've been trying to use drush make on a very simple test project (an empty folder containing just the make file) to see how it works, but nothing happens. In the shell, there's a one second delay after I press ENTER, and then the empty prompt comes back. There's no error or confirmation message, and nothing changes in the test folder (not even en empty folder is created).

The command I use is simply: drush make test.make.yml test
(Of cource I'm already in the correct folder when I type this command.)

If I omit the last parameter (e.g. drush make test.make.yml), then drush waits one second, then asks if I want to "make new site in the current directory ? (y/n)". But if I press Y, still nothing.

drush make -h shows the expected help information.

I'm using drush v.6 on a Windows 8.1 xampp local setup. The usual drush commands (e.g. drush dl views, etc) work fine, though. (As far as I can tell anyway: I'm not an advanced user.)

I tried with the example file provided in the drush/make documentation, and I also tried to simplify the content of my make file to the max:

api: 2
  core: 7.x
  projects:
    drupal:
      version: 7.36

Still nothing.

Is there something I'm missing?

4

I might be mistaken, but I think the YAML format for Makefiles is for Drush v.7 and later. I am using the "old" format with Drush v.6 (and Drupal 7), also on Windows

Might that work with the sample below?

; Drush Make API version
api = 2
; Drupal core
core = 7.x
projects[drupal][version] = 7.36

Hope it helps,

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.