1

I transferred my website to a live hosting from my local computer. Now the image files don't seem to upload to the correct folders. The images that I added while the site was local appear fine, but if I try to add new ones the preview is broken. However, if I click the link next to the preview I get the image. It seems like the images are not going into the sites/default/files/style/... sub directories. All of directories have permissions of 0755 or 0775.

  • Still sounds like a permissions problem, make sure the directories in /files are all 775 and that your web server group can access/modify the files – Patrick Ryan Apr 11 '15 at 20:15
  • I changed all the directories to 775, but still the same thing. I don't run the server so I can't modify server user settings. – Gamegoofs2 Apr 11 '15 at 20:30
  • If apache has no access, it won't be able to create the styles. You will need to either add the owner to the apache group or set the group to apache. Also note that the apache group name differs between os's – Patrick Ryan Apr 11 '15 at 21:13
  • I don't have control over the server to modify user settings. – Gamegoofs2 Apr 11 '15 at 22:03
  • 1
    Then you'll need to ask your server admin or hosting company to make the changes – Patrick Ryan Apr 11 '15 at 22:31
0

Please check admin/config/media/file-system page on your site to see if the file directories are set correctly and accessible by Drupal. It's possible the server is configured differently from your local installation or the relative directories are set incorrectly in the configuration fields.

As for the comments about permissions and ownership - it seems you can run chmod on the directory, so the intention was that you would run chown on the directory to set the owner to the Apache group (on Ubuntu it www-data).

  • I realized later that I was able to upload images last Monday. Now I can't. I didn't change anything between now and then. The public file system path is sites/default/files. No red flags on the file system page either. – Gamegoofs2 Apr 12 '15 at 16:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.