3

I'm trying to get a Drupal 6 site up and running with the Vagrant Drupal Development project.

I can get VDD going.. get my site installed, the database imported etc.. but I need to make VDD use an old version of PHP. I see some instructions online that say you can set which PHP version to use, but it isn't happening.. it doesn't say where in the json the setting needs to appear.

I tried with the following json, but it ended up as PHP Version 5.4.39-1+deb.sury.org~precise+2 :

{
  "php": {
    "version": "5.2.17"
  },
  "vm": {
    "ip": "192.168.44.44",
    "memory": "1024",
    "synced_folders": [
      {
        "host_path": "data/",
        "guest_path": "/var/www",
        "type": "default"
      }
    ],
    "forwarded_ports": []
  },
  "vdd": {
    "sites": {
      "drupal6site": {
        "account_name": "root",
        "account_pass": "root",
        "account_mail": "[email protected]",
        "site_name": "drupal6site",
        "site_mail": "[email protected]",
        "vhost": {
          "document_root": "drupal6site",
          "url": "drupal6site.dev",
          "alias": ["www.drupal6site.dev"]
        }
      }
    }
  }
}
3
  • 1
    Who or what is VDD? Please EDIT your question to explain this acronym and/or add a relevant hyperlink ... Jul 25, 2015 at 8:59
  • oops missed that part.. edited
    – Damon
    Jul 26, 2015 at 18:55
  • OK, next recommended edit: '... some instructions online ...': please share the url of that also ... Jul 26, 2015 at 19:03

2 Answers 2

1

VDD of 8 version doesn't support the feature of changing PHP version. You may try other Vagrant box for Drupal. For example this one, it has very good documentation.

2
  • So on the site where it says "Note, VDD works great with Drupal 6, 7 and 8." it is incorrect? The link you provided mentions that it is possible to change PHP version
    – Damon
    Jul 22, 2015 at 23:18
  • 1
    You can install Drupal 6 on VDD, but you can't change PHP version. The last comment on the page says "As it appears it's really hard to maintain this feature. 8.x-1.x branch most likely will not support it. Anyway after releasing stable 8.x version 7.x branch will be removed. So, I propose to leave this issue as "won't fix"."
    – Andrew
    Jul 23, 2015 at 3:35
0

After having issues with both vampd and vdd I used a Turnkey linux iso for my virtualbox. They have one with Drupal 6 but I am using the Drupal7 one. Installs easily, configures one NAT adapter but you have to do the Host-only adapter yourself. Either start from the site they give you or replace it with your own existing site. I renamed the /var/www/drupal7 site folder and then did a ln -s my.git_cloned.site drupal7 to just sym link my site (managed in git) to the existing apache configuration. Comes with phpmyadmin out of the box.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.