1

Summary

Using Imagefield and the Insert modules, I can insert into CKeditor "Automatic" image styles, but not "Lightbox" styles.

What I've tried

This suggests that CKeditor is filtering the inserted code. I've tried disabling (a) Security>Security filters "HTML filter" (b) Advanced content filter (c) Advanced options>Custom JavaScript configuration "config.allowedContent = true;"

How to

I've added an imagefield to my content type. In Create node, I upload an image, and a Style box appears with "Automatic" and pre-defined imagecache options. If I select Automatic and click the Insert button, my image appears in CKeditor. If I select one of the imagecache/lightbox options and click Insert, nothing happens.

Set-up

I'm running: Drupal 6.35, CKeditor 1.15 (with CK editor 4.3.4), Insert 1.2, ImageField 3.11, imagecache 2.0-rc1, Lightbox 1.11.

Any suggestions?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.