1

I'm trying to setup a new project using the Drush make command. I'm working on localhost (xampp) on a Windows 8.1 machine.

The problem is that if a module present in my make file requires an external library (e.g. colorbox or plupload), make will detect that and will download said dependency, but then will fail to decompress it, resulting in the following error:

plupload-7.x-1.7 downloaded.                                                [ok]
Found makefile: plupload.make                                               [ok]
plupload downloaded from                                                    [ok]
https://github.com/moxiecode/plupload/archive/v1.5.8.zip.
Unable to unzip                                                          [error]

As a result, the whole make operation is aborted.

I searched for a solution and found this stackoverflow answer that seems to address my problem but is not very detailed. I tried using Cygwin (x64), found an "unizp" package in it, tried to download it and copy the unzip.exe file in the Program Files (x86)\Drush\GnuWin32\bin folder, but now when I run my make project I have a new error message, this time as a dialog box (not in the console, then):

The program can't start because cygbz2-1.dll is missing from your computer.
Try reinstalling the program to fix the problem.

Followed by a unzip.exe has stopped working Windows dialog box.

I can find the missing DLL (cygbz2-1.dll) in the C:\cygwin64\bin directory. So I tried adding this path to my PATH environment variable (and restarted my computer to be sure), but I still have the same "missing DLL" error.

Is there something I'm doing wrong (I'm not familiar with cygwin at all, so I don't know if I'm using it right...)?

1

Get unzip for windows: http://gnuwin32.sourceforge.net/packages/unzip.htm It solved the "unable to unzip" problem for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.