1

I am experiencing a very annoying problem with ckeditor 4.4.7.3. Everytime a <br/> is entered into the editor, it displays the next line right below the existing line as one would expect. However, when you view the page, an extra <br/> tag appears along side the original <br/> tag. You can see this when looking at the source for the page.

Rendered output
<p>
  <strong>Age</strong>
  <br>
  <br>
  24
</p>

Looking at the source html while in ckeditor reveals that there is only one <br/> there.

Source as seen in ckeditor
<p>
  <strong>Age</strong>
  <br>
  24
</p>

This would seem to indicate to me that Drupal is adding line breaks while rendering the output. I have tried disabling the option: Convert line breaks into HTML (i.e. <br> and <p>) in the text format, but that doesn't change anything. I have also disabled JavaScript to see if some JavaScript file is doing this - but that makes no difference either.

I have googled this issue and have not found a solution yet (other people have been experiencing as well but no solution given). I would appreciate any suggestions in fixing this problem.

3

As it turns out, disabling the option: Convert line breaks into HTML (i.e. <br> and <p>) in the text format does make a difference. I needed to flush the cache to see the results. Hopefully this will help other people who experience this problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.