1

I'm working on a multi-language site and would like to pre-define the language per content type (as e.g. described here in the answer) but can't get the vertical tab "nodes" to show up.

The "taxonomies" tab however does show up – so I guess sometings are actually working correctly.

i do have a couple of content types with the publishing setting "Multilingual support = Enabled" – but still none of them shows up in the Entity translation options section. What I would like to achieve is one a one-content-type-per-language setup – therefore I would like to set the default language accordingly on the Entity translation page . What am i missing? Any pointers would be appreciated.

Screenshot from the Entity translation interface:

enter image description here

1

I just recently had this problem and after 6 hours of searching for a solution I tried the following, which seems to work for me:

Without having Entity Translation installed first update Internationalization (i18n) to the latest version. Then setup the necessary submodules like "Field translation" that you need from Internationalization.

After this is all done then download and enable Entity Translation, go to Entity Translation settings under /admin/config/regional/entity_translation and enable "Content" under "Translatable Entity Types".

If you haven't configure any of your content types to be translatable with field translation (under publishing options) you won't see anything here. So after doing this for at least one of my content types this page showed the Content tab to add the correct settings for each content type.

  • Thank you! But I still can't get a one-content-type-per-language setup to work: if I enable the "field translation" (under publishing options) I do actually get the 'node' option under 'Entity translation' – and I can set a default language for that content type. However that does not seem to have any influence on new nodes. So instead I set the content type to "translatable" (under publishing options) and tick all three options under "Multilingual settings" – that has almost the effect what I was looking for. – tillinberlin Apr 28 '15 at 11:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.