1

I have an odd error coming from Drush when I perform module updates and other commands (it's most consistently comes from module updates). Near the end of the command execution this message pops up:

xmlrpc() error: (-1001) unable to parse URL

Some cursory Googling produces that its likely an error popping up in drupal_http_request. I'm not sure where however since I'm not too familiar with the Drush code base.

I ran drush with the --debug switch for more information but that didn't tell me much other than this message typically pops up after the drush_cache_command_clear() being executed.

What is causing this error?

3

Turns out the issue was the APC module. After some testing I was able to isolate the issue during cache clear.

[shawnconn@host www]$ drush cc all
'all' cache was cleared.                                                                                                                                                                                                                                 [success]
xmlrpc() error: (-1001) unable to parse URL                                                                                                                                                                                                              [error]
[shawnconn@host www]$ drush dis apc
The following extensions will be disabled: apc
Do you really want to continue? (y/n): y
apc was disabled successfully.                                                                                                                                                                                                                           [ok]
You need to enable the APC module for remote cache clearing to work. Run drush pm-enable apc.                                                                                                                                                            [error]
[shawnconn@host www]$ drush cc all
'all' cache was cleared.                                                                                                                                                                                                                                 [success]
[shawnconn@host www]$
2

It seems likely that you have not correctly specified the URI for your site. You can do this in one of several ways:

  1. --uri=http://example.com on the commandline.
  2. 'uri' => 'http://example.com' in a site alias.
  3. $options['uri'] = 'http://example.com' in a drushrc.php file.

For the purpose of most Drush commands, it is sufficient to use the name of the folder that contains the settings.php file as your uri -- or you do not need to specify the uri at all if the sites folder is 'default'. However, some modules will need the full URI, including the http:// protocol, or you will experience problems similar to what you describe above.

  • Thanks for reply Greg (and all for all the awesome work with Drush!). I tried all those options and I still wasn't able to get rid of the problem. Turns out the cause was the APC module. – Shawn Conn May 9 '15 at 6:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.