2

I'm putting this question in the Drupal forum rather than a CSS forum as I don't know if I just have a CSS issue or if the issue is more Drupal, maybe how I'm using the .info file.

I'm using Drupal 7 with UberCart and the AT Commerce sub-theme of Adaptivethemes. If I put my CSS in styles.base.css they take effect. However, it I put my CSS in a separate CSS then they do not.

I edited at_commerce.info so I have this

// CSS
stylesheets[all][] = css/styles.custom.css
stylesheets[all][] = css/styles.base.css
stylesheets[all][] = css/styles.modules.css
stylesheets[all][] = css/styles.settings.css
stylesheets[all][] = color/colors.css
stylesheets[all][] = css/uc_product.css

I tried styles.custom.css as the first in the list as shown above and the last in the list and it make no difference. styles.custom.css is empty except for the 2 styles I'm trying to put there. When I put the 2 styles in styles.base.css I am putting them at the bottom of the file.

3
  • I failed to say clearly that the 'separate css file' is styles.custom.css. The styles don't work when I put them in this file.
    – klequis
    Apr 26, 2015 at 0:33
  • Your css should work. Maybe your other css has the same style, which overwrite?
    – CocoSkin
    Apr 26, 2015 at 2:11
  • Thanks CocoSkin. Looking at firebug I don't see that. However, requirements change, as did the requirement that needed this style such that I no longer need to introduce the new style so going to stop looking for a solution.
    – klequis
    Apr 27, 2015 at 22:06

1 Answer 1

1

Just to eliminate a possible cause of your problem: if you have enabled CSS aggregation then you must clear the cache before changes to CSS files become active.

1
  • Thanks for the tip Pierre. I've done that and it is not the problem.
    – klequis
    Apr 26, 2015 at 16:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.