1

I'm using Acquia Dev Desktop 2 with Drupal 7. On PHP version selection menu, I only see "5.3.29", "5.4.33", "5.5.17".

Is it possible to switch PHP version to PHP 5.2.17 since most of my hosting provider based on PHP 5.2.17.

Or would you recommend anything other than Acquia Dev Desktop 2?

Thank you.

  • 1
    Change your hosting provider ASAP, anyone offering you 5.2 is either stuck in the past or has a requirement to provide server space for websites using legacy technology. Drupal will run just fine on newer and better software, so you should bring yourself into this decade and go up to at least 5.5, preferably 5.6. I'm surprised Acquia even provide an option for 5.3 and 5.4, those are both so old as to be considered obsolete now too. 5.3 isn't even supported any more. – Clive May 3 '15 at 10:45
  • I acknowledge the problem, but I'm afraid changing is not an option right now. As I observed, 90% of trusted hosting providers still use PHP 5.2.17 in Thailand. I, however, plan to buy a server for my company to solve this problem in the future. – Rik May 3 '15 at 14:31
3

They dropped PHP 5.2 support with DevDesktop 2. It has hit EOL so you really shouldn't be developing against it.

That said, if you really want to do this, you can find old versions of DevDesktop that used PHP 5.2. I would guess you might hit problems if your end goal is to deploy to AcquiaCloud.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.