3

I'm trying to update Drupal core from 7.28 to 7.36. (not using Drush)

When running update.php I get:

Unresolved dependency System (Version >=7.33 required) Relation requires this module and version. Currently using System version 7.28

It seems like the Relation module wants a version 7.33 or higher, and yet it won't let me upgrade to a version 7.33 or higher. Not quite sure how to get past this.

Relation ver. 7.x-1.0-rc7 (It didn't seem to have any trouble when I upgraded to 7.28).

How can I resolve this?

2

The reason for your error is because of the last line in the info file of the Relation module, i.e.:

dependencies[] = system (>=7.33)

In regular English it is something like "This version of the Relation module requires Drupal core to be at a level which is at least 7.33".

To resolve it perform these steps:

  1. Disable of the Relation module.
  2. Retry your core upgrade again (that error should not show up anymore, as per step "1.").
  3. Re-enable the Relation module again.

I'd be interested to hear what result you get in that scenario ...

Note: since your site is pre 7.32, you may want to also work on things such as what is in suggested in the answers to Drupal SA-CORE-2014-005 - How to tell if my server / sites were compromised?

|improve this answer|||||
  • 1
    It's my upvote (made before the edit) because I think it is a valid solution to the problem as it has been described. I can't vouch for whether or not it fixes the OPs problem though. – rooby May 6 '15 at 14:52
  • Merci (thanks!) rooby ! It's one of the typical upgrade issues one can run into, right? Maybe we should consider a patch to enhance the typical error message (something like "temporary disable this module while upgrading from an earlier core version" ... Would you agree? – Pierre.Vriens May 6 '15 at 14:57
  • I'm not sure it would be very common because if upgrades are being done properly it should have previously stopped you upgrading to the version of relationship that was incompatible with the core version, but disabling the module should definitely stop the warning and allow the core upgrade. – rooby May 6 '15 at 15:16
  • Well, good point. Actually I was also wondering already "how come this situation could happen?". Other thought: "only now upgrading from pre-7.32???" ... – Pierre.Vriens May 6 '15 at 16:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.