0

I Use D7, CKeditor v 1.16.7 and Media v 1.5.7, all other modules are up2date and the site itself works fine.

I don't recall any special change at the site that would avoid this module of working, yet suddenly it's upload button was removed from CKeditor's Full HTML palette (img 1) while appearing fine in Filtered HTML palette.

Facts:

  1. The CKeditor "Full HTML" profile's settings seems just fine (img 2).

  2. Permissions are fine (I'm the Admin, img 3).

  3. Rebuilding type information for media, didn't help.

Any ideas?

enter image description here enter image description here enter image description here

7
  • is it showing any recent errors in the log related to either module?
    – Geoff
    Commented May 6, 2015 at 20:47
  • Went to "Recent log messages" but couldn't find anything special there, at least not something relating to the phrase "Media".
    – user16289
    Commented May 7, 2015 at 8:11
  • It seems that the problem only occurs in "Full HTML" profile but not in "Filtered". I've corss-chekced the profiles' settings and couldn't find any differences... strange isn't it?..
    – user16289
    Commented May 7, 2015 at 10:23
  • it is - sorry, I don't have any suggestions for you... I was banking on an error
    – Geoff
    Commented May 7, 2015 at 14:18
  • Have you tried re-installing the module?
    – No Sssweat
    Commented May 7, 2015 at 14:59

1 Answer 1

0

Solved! For some reason (most probably a bug) the Media module button wasn't added automatically to the Full toolbar even after I check-marked "Plugin for inserting images from Drupal media module" in "Editor appearance" at the desired profile's settings page.

So, What I did was after I check-marked "Plugin for inserting images from Drupal media module" I just went on to add the button manually from "Available buttons" to "Current toolbar" (see img), saved, cleared cache, and Vwalla - it worked again!

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.