I've installed CKEditor in my drupal instance and all seems to work well until I realized, I can't change the text size (missing drop down). I went to admin/config/content/ckeditor and selected and saved Toolbar full from the examples, which feature a Size dropdown as shows in the "current toolbar' preview. I did this for both existing profiles, Advanced and Full. However, if I then go to admin/structure/block/add to add a new block, CKEditor still does not show a size drop down so that I could change the text size. Why not, what am I missing?


I went to http://ckeditor.com/download and downloaded the full package which I then just copied to my existing sites/all/modules/ckeditor/ckeditor overwriting the existing standard package copy. I've reset the cache`, however what I'm seeing now is this:

CKEditor toolbar

The Size drop-down is visible but other buttons have failed to load their icons.

Any suggestions?

  • Did you flush the cache?
    – No Sssweat
    Commented May 11, 2015 at 18:26
  • @NoSssweat Yes I have, see EDIT 1 above
    – stdcerr
    Commented May 12, 2015 at 13:06
  • You have the latest version of the drupal module, 7.x-1.16 ?
    – No Sssweat
    Commented May 12, 2015 at 18:41

2 Answers 2


It's possible you are using a version of CKEditor (the editor, not the drupal module) that doesn't have the font size and family plugin.

See the different versions at http://ckeditor.com/download (click the "Compare packages" link to see what is included in each package).

On that page you can see that only the full version has the "Font Size and Family (font)" package, so if you are using one of the other version then it won't have that package.

It is also possible to use the "Or let me customize CKEditor" option to create a custom version of CKEditor that contains just the plugins you require. If using that make sure you include the "Font Size and Family (font)" package.

There is an issue here on Drupal.org regarding messages to the admin to notify them of missing plugins.

  • please see EDIT 1 above
    – stdcerr
    Commented May 12, 2015 at 13:05

I "fixed" it by completely reinstalling CKEditor as described on http://docs.cksource.com/CKEditor_for_Drupal/Open_Source/Drupal_7/Installation that worked just fine!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.