0

I've got a view for the content type article to display them. I'd like it to display the full content or the teaser.
As a format I've chosen unformatted list.

But whatever I choose (rendered entity/display suite/teaser/full content) I will only see the titles in my view and a read more link.

The body field is Long text and summary but I didn't use the summary so far.
Does anybody know this behaviour? I'm sure it's just a small setting somewhere but I didn't see this before and I ran out of ideas where to search for the solution.

Edit: Even in the content type, everything looks fine. In full content and teaser, all fields are beding displayed.

  • Just try this, Go to the manage display of your content type and set the formats of your fields as required and then check your view's result. – Anusha May 11 '15 at 4:53
  • Not sure .. there in this Dropdown I see: Default, Plain Text, Trimmed, Summery or Trimmed, Hidden Display-wise, there aren't other settings but the hidden/inline/above for the label. – Chris May 11 '15 at 8:09
  • Try using the trimmed option. Did you tried using these options? Are there any results? – Anusha May 11 '15 at 8:13
0

Just to be sure, navigate to admin/structure/views within your site. Then perform an "edit" of your view. On the next screen, select the "views display" for which you're having this issue. Then verify if all the "fields" that you want to be shown in your view are actually included.

E.g: if you'd only have field "Title" shown in the list of fields (and "Content: Body" is not in the list of fields to be shown), then that would explain your issue. In that case, use the "Add" button next to "fields" to add the fields you want to be added.

Curious to hear if this is the "... small setting somewhere ..." that you were looking for.

  • I've set up like: Format: Unformatted list - Settings Show: Content - Full content So there are no fields. In the preview I can see the title and body. But in the frontend I can't anymore. If I use fields it's working - I'm just confused that rendered entity or full content don't show anything but the title - usually that's not what happens, right? – Chris May 11 '15 at 1:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.