I installed Drupal Chat just to try it out. I couldn't get it to work and now I can't disable the module.

In /admin/modules, the check box is selected but not enabled. i.e. it is active and I can't deactivate it.

Can anyone help me?

(and, once disabled, how can I un-instal it?)

Update: I forgot to mention that there are no dependencies on the module.

5 Answers 5


usually if conventional uninstall wouldn't work i'd try clearing the module's entry from system table removing tables from the module installation (after backing up the data) clear the cache and reinstall.. hope it works for you ...cheers!!

  • +1 thanks for taking the time to help. Unfortunately I don't understand a word of that. Can you point me at a URL? Nov 23, 2011 at 0:02
  • 1
    @Mawg doh... haven't read it any place before.. but for the sake of clarity -when a module say X is installed an entry is added to the system table of drupal for it... -first check the .install file of X (if it has one) to see the table names it creates -use something like phpMyadmin to backup those table data as SQL dump -delete tables created by X, also delete the entry in table system created for table X, find it by the module name as either X or sites/all/modules/../X -go to Performance(admin/settings/performance) clear cache and reinstall module and restore data from the dump. Nov 23, 2011 at 6:07
  • 1
    From @Mawg's comment above, he appears to be on a shared host so may not be familiar with database access.
    – David
    Nov 23, 2011 at 12:16
  • +1 yes & no. Shared server yes, but I do know MySql & PhpMyadmin. I will follow Opitmus's advice and if that works will award the answer. (+1 to Optimus too. Thanks for the details, I am a Drupal n00b & wouldn't have known) Nov 25, 2011 at 0:45

Other modules might be dependent on it. For example, if you also enabled Drupal Chat Notifications, you would need to disable that first.

  • 1
    Exactly, it looks like module dependency issue. Nov 20, 2011 at 14:45
  • +1 each. Sorry, I forgot to add that there are no dependencies, which is what I had thought myself Nov 21, 2011 at 0:15

I agree with adam; however, if you are using Drush on your server, typing in "drush dis drupalchat" will return a notification of the dependencies, and will allow you to disable them. Make sure to delete the module folder and update your database.

  • 1
    One other thing you could check is the user permissions, have you changed them since you installed the module?
    – David
    Nov 21, 2011 at 7:09
  • My hosting co. won't let me have command lien access. So, no Drush, I guess Nov 22, 2011 at 23:09
  • that's unfortunate, but "if all else fails" use an ftp client such as Filezilla to remove the module folder and run the clean up instructions that the other answers suggest. By the way you can use Filezilla to set folder/file permissions on shared hosting.
    – David
    Nov 23, 2011 at 12:13

If dependencies are not an issue then may be the module may have been corrupt . Try reinstalling and then uninstalling the module..


This answer is more general than DrupalChat module. Some modules install content types and field types. My solution is for Drupal 7.x. It's likely similar on other versions. To disable:

BE SURE to back up the data base before doing these steps.

1) go to .../admin/structure/types. Look for the content type associated with the module. If it's not there, this is not the solution.

2) if there is such content click on manage fields. Remove any field that is also associated with the module. You have to agree to the "this cannot be undone warning".

3) back to admin/structure/types and remove the content type. Again agree to "this cannot be undone warning".

4) go to ../admin/modules and disable the module.

This should work. You may have to work through additional required by modules and any content and fields that those modules added. (Lather, rinse, repeat.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.