0

So, I'm getting what seems to be a common error in working with SASS in a windows environment. "Error: It's not clear which file to import @import'print';" using zen 5.

I have tried changing the sass-globbing versions, and even tried different variations of the @import statements syntax (e.g. @import "print/", "print/", "print//" etc, nothing seems to affect the error.

The issue is that while there are plenty of people reporting this issue, there doesn't seem to be a clear picture of how to fix or address the issue, suggesting changing developing environment is not helpful.

At it's face, the issue is that the SASS parser can't seem to tell the difference between the partial _print.scss and the other empty print.scss files in the same folder.

Do I need the empty print.scss file, or can I rename it? Or can I rename the partial _print.scss to something else? Is there a non-hack way to fix this?

0

So, this ends up being more of a environment/sass issue I post this here because I encountered in working with Omega, and I figured someone else would bump into this. Depending on your set up, especially if you're using a task manager, SASS file globbing might not be functional.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.