2

I am using Drupal -7 and my website is on cloud(not local host). This is NOT a multi site and using Omegasubtheme.

I have just updated workbench Moderation module from 1.3 to 1.4 and have also added Workbench Media module(7.x-1.1) to my dev. site. After running update script, I got bunch of errors on my site. So, I again moved Worbench Moderation Module from 1.4 to 1.3.

Devel Generate and Devel Node Access Modules were enabled in my site and I made those module disabled.

After that, I got these errors so I made them enabled again. I found this thread but, this is for database.inc for memory allocation error message in database.inc.

Devel Module

Devel Modules

Can anyone help me how to get rid of these errors?

Errors which I got on front page:

Warning: require_once() [function.require-once]: Unable to allocate memory for pool. in _registry_check_code() (line 3177 of /docroot/includes/bootstrap.inc). Warning: require_once() [function.require-once]: Unable to allocate memory for pool. in _registry_check_code() (line 3177 of /docroot/includes/bootstrap.inc).

Errors on Front page

Errors on available updates module page:

Warning: require_once() [function.require-once]: Unable to allocate memory for pool. in menu_execute_active_handler() (line 515

of /docroot/includes/menu.inc). Warning: require_once() [function.require-once]: Unable to allocate memory for pool. in module_load_include() (line 330 of /docroot/includes/module.inc).

Errors on Modules page

1

It would be interesting to see if your problems could be related to the "memory limit", which might not be high enough (anymore), especially because of the "... have also added Workbench Media module ...".

Assuming this is NOT a multi site, consider editing your /sites/default/settings.php, and change the line to set the memory limit. If it is a multi site, then edit the settings.php file related to the site where you are experiencing the problem.

That line in settings.php should look similar to this:

ini_set('memory_limit', '100M');

The '100M' in it might be some other number. Whatever the number is, try to increase it with like 50%, or maybe even double it to see what happens after you do so (of course do not forget to save the file after increasing that number).

Another possibility that you may want to verify, is to "perform a clear cache" (it doesn't hurt, and occasionally helps solving various issues).

Curious to hear if that helps somehow ...

  • Memory is: APC to 128M Few hours from after clearing Varnish Cache, those errors gets just disappeared when Workbench Module is 1.3. But, when I updated the module to 1.4 again, then I got SQL server errors as well some other errors.(Will try (drupal.org/node/1260112)) Notice: Undefined property: stdClass::$is_current in workbench_moderation_node_data() (line 1230 of /mnt/www/html/example.com/docroot/sites/all/modules/workbench_moderation/workbench_moderation.module). I will update if I will get error free page with workbench moderation module-1.4 – Vidushi May 13 '15 at 19:14
  • Thanks @Pierre.Vriens. I think problem arise because of memory issue. I was not able to find ini_set('memory_limit', '100M'); in my settings.php file. But, I just disabled some modules to avoid m/m issue and perform clear cache. and errors are gone. – Vidushi May 27 '15 at 15:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.