1

I'm try to set up Mailchimp module but i keep geeting Failed to load MailChimp PHP library. Please refer to the installation requirements.

My steps:

  • disable mailchimp module

  • install composer_manager package locally

  • run: curl -sS https://getcomposer.org/installer | php on my root
  • change composer.json(which lay on my root) - see it below
  • run: php composer.phar install --no-dev
  • mailchimp/mailchimp directory is installed in my /vendor folder

  • clear cache, re=enable module but still getting the error. In my report i see that the module cannot be found.

What i'm doing wrong??

{
    "name": "drupal/composer_manager",
    "type": "drupal-module",
    "description": "Composer Manager is a bridge to best-in-breed, standards compliant PHP libraries that are managed by Composer and Packagist.",
    "homepage": "http://drupal.org/project/composer_manager",
    "license": "GPL-2.0",
    "authors": [
        {
            "name": "Chris Pliakas",
            "email": "opensource@chrispliakas.com",
            "role": "Project Lead"
        },
        {
            "name": "See contributors",
            "homepage": "http://drupal.org/node/1929436/committers",
            "role": "Developer"
        }
    ],
    "support": {
        "issues": "http://drupal.org/project/issues/composer_manager"
    },
    "require": {
        "php": ">=5.3.0",
        "mailchimp/mailchimp": ">=2.0.4"
    }
}

MailChimp module => 7x.3-3

mailchimp library => 2.04

1

Here are some steps to troubleshoot this error according to this thread: Issue #2054037 Failed to load MailChimp PHP library. Please refer to the installation requirements. (provided by @rtome, above)

  • Re-read the instructions in MailChimp module's README.txt
  • Clear the cache
  • Ensure Libraries module is installed and is working properly
  • Ensure Mailchimp library is located at sites/all/libraries/mailchimp
  • Check your versions:

MailChimp module 7.x-2.x requires MailChimp library 1.3
MailChimp module > 7.x-3.x requires MailChimp library 2.04

  • If MailChimp library updated, reinstall MailChimp module
0

The mailchimp module 7.x-2.x and 7.x-3.x branches rely on MailChimp’s API version 2.0 and has became unsupported by MailChimp at the end of the year 2016.To upgrade to the latest version, please go through with the following link http://cgit.drupalcode.org/mailchimp/tree/README.txt.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.