0

I installed Open Outreach via Acquia Dev Desktop on my Win 7 machine.

I am using Firefox, but the problem is also present in IE.

I deleted the second sample blog entry that came with the distribution. When I click the remaining blog (Welcome to our new website) the image that shows on the home page does not show on the blog page. Furthermore, when I attempt to upload a new image (after deleting the old one) I get a "Destination *" message, but no box to type in next to it. When I click Next I get "An illegal choice has been detected. Please contact the site administrator.".

In the message log I see the following.

Illegal choice public in Destination element.

http://openoutreach-7-x-1-19.dd:8083/media/browser?render=media-popup&types%5B%5D=image&activePlugins=&enabledPlugins=&schemes%5B%5D=public&schemes%5B%5D=private&file_directory=&file_extensions=png+gif+jpg+jpeg&max_filesize=&uri_scheme=public&min_resolution=&max_resolution=1000x1000&plugins=undefined

I am a newbie. Can you give me simple instructions as to how to fix this?

Thanks!

0

It appears that, by looking at the code that causes that "Illegal choice public in Destination element" error you got, "Public" is not an acceptable choice in the element with name "Destination". Not sure if this rings any bell, but maybe it helps somehow.

After you find the solution (reason) for this problem, you probably also solved the remaining error as you mentioned about ' ... "Destination *" message ...'

1
  • Hmmm ... Where would I go (directory & file) to poke around and try to solve this? As I said, I'm a newbie. I don't speak CSS or php very well. – Sam Stamport May 17 '15 at 15:37
0

After learning some more about how Drupal works I downloaded a fresh copy of Open Outreach and installed it alongside my troublesome copy. I discovered that I had accidentally messed with the front page view. I discovered that you can export and import views so I exported from the fresh copy & imported to the troublesome copy. Problem solved!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.