We have a multilingual Drupal 7 site, and after turning on the first translation, we realized that one of the third party modules we're using, a slider module (comes with Eventus theme, it's a module the vendor built (or perhaps bought and extended/branded)). The slider module is not multilingual aware and it is routing all users to the same URL (which sends them back to the default language), regardless of the active language.

We're evaluating our options to address this, and one idea (that I am unsure if it is possible) is to make the slider links go to a "language neutral" URL, which will then forward them on to the user's currently active language for any given URL. However, so far I haven't been able to figure out A) if this is possible and B) if it is possible, how to construct the URL. So, is it possible, and if so, how would I set this up? Open to suggestions.

The slider module's content is currently identical for all language versions of the site.

To try and clarify, I'm going to use example the following example URLs:

/about -- this is the default, primary language (english) version of the "about" page /pt-br/sobre -- this is the translated, Português version of the "about"

The first "slide" in the slider says "Learn more about us!" and links to the /about.

Our goal is to make Drupal aware of the user's current language setting, and if they click on a link that sends them to /about, but their language is currently set to Português, it will automatically redirect them (or at least provide them) with the Português version of the "about" page.

Is this possible, and/or is there a better way to accomplish this?

  • Negative on both, added some more info to question. D7 and commercial slider module.
    – Josh
    Commented Jun 10, 2015 at 11:01
  • @Pierre.Vriens, I added some clarification, let me know if it helps.
    – Josh
    Commented Jun 16, 2015 at 15:10

1 Answer 1


I'm not familiar with the "slider" module. But from the example URLs you added, it seems to me that at least you should check your configuration at Configuration -> Languages -> detection and selection: the order specified there should be 'URL, Default, User', and not something like 'Default, URL, User'. It could well be that that is all that's needed here ...

Curious to hear what the result of checking this will be ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.