2

I am using Drupal Ckeditor (The main one, not the WYSIWYG module).

I would like to add buttons to the interface for inserting <quote> and <cite> tags.

How can I do this?

It already has a blockquote, but I would like <quote> and <cite> as well.

7
  • you need to create a custom ckeditor plugin. You can find tutorials here docs.ckeditor.com/#!/guide/plugin_sdk_sample
    – No Sssweat
    May 18 '15 at 23:33
  • @No Ssweat -The plugin in the sample tutorial doesn't seem to work in Drupal. It will load in the UI, but the button cannot be added to the toolbar. Is there a trick to making the button work?
    – big_smile
    May 19 '15 at 21:03
  • You must be doing something wrong, did you do everything I posted as comment on Drupalist answer? In admin/config/content/ckeditor/edit/Advanced (which is FILTER HTML) In Editor Appearance it should be listed under "available buttons" which you then have to drag up into "Current toolbar".
    – No Sssweat
    May 20 '15 at 8:58
  • Did you create the icons folder with a png image inside your plugin folder?
    – No Sssweat
    May 20 '15 at 9:05
  • @NoSssweat Yes, I did. I also tried downloading the sample plugins in the link you posted. I can activate them in the Drupal UI, but the button does not appear. Do the sample plugins work for you?
    – big_smile
    May 20 '15 at 13:07
1

Here is a good tutorial in Custom buttons on CKEditor or Adding CKEditor Plugins Manually in Drupal . Before asking the question you should have let us know what you have done so far.


If you were checked the links, you would see that in the Adding CKEditor Plugins Manually in Drupal and Add Plugin Part of CKEditor Module section it explained where to put the plugin.

7
  • By default, CKeditor comes with several plugins listed (but not installed) in the Drupal UI under "editor appearance". If I download these plugins and put them in my Drupal Ckeditor Plugin folder, I can activate them. However, how do I activate a plugin that is not listed in the Drupal UI? If I make my own plugin or download one from Ckeditor.com, it doesn't appear in the Drupal UI. If I try to activate it by using "advanced options" (e.g. config.extraPlugins = 'codeTag';), then Ckeditor fails to load on a node.
    – big_smile
    May 18 '15 at 20:46
  • 2
    you need to put them in sites/all/modules/ckeditor/plugins DO NOT put them in sites/all/modules/ckeditor/ckeditor/plugins. Then go to admin/config/content/ckeditor/edit/Advanced (<-- this url is for filter HTML) and under Editor Apperance, there is a plugins section, check mark your plugin.
    – No Sssweat
    May 18 '15 at 23:40
  • 2
    Then go to admin/config/content/formats/filtered_html and add the <cite> tag into the Limit allowed HTML tags section.
    – No Sssweat
    May 18 '15 at 23:45
  • 1
    PS: never allow regular users to type in FULL HTML as they can embed evil.js onto your site.
    – No Sssweat
    May 18 '15 at 23:47
  • @big_smile I updated the answer
    – M a m a D
    May 19 '15 at 3:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.