Fatal error: Class 'SelectQuery' not found in /home/content/71/11241671/html/drupal/includes/database/database.inc on line 813

We built a site in a subfolder called /drupal while building the site, and then moved the files to the root directory when we were finished but it gave the above error on a WSOD.

I have tried:

  • flushing the cache before moving
  • tried the registry rebuild
  • truncating and replacing the registry and registry_file tables with a fresh install copy, and rebuilding the registry again
  • rewrite base in htaccess
  • setting a new base url in settings.php

But nothing has worked.

The second we put the files back into the /drupal folder, it works again. It also looks like the error mentions the file in the /drupal directory, which isnt there anymore.

This is on 7.37

Anyone have any ideas?

1 Answer 1


Rolling back this patch... https://www.drupal.org/node/2170453 solved the first problem, and then using htaccess to define the correct php version fixed the next error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.