0

I'm running a D7 core update and all but one database updates pass. The one that doesn't pass gives me the following error message:

Failed: DatabaseSchemaObjectDoesNotExistException: Cannot add field erg_field_data_field_carousel_slide_url.field_carousel_slide_url: table doesn't exist. in DatabaseSchema_mysql->addField() (line 325 of /Applications/MAMP/htdocs/my_site/includes/database/mysql/schema.inc).

I tried running a registry-rebuild, but I still get that error when I ran the update again.

I do have a table in my database called erg_field_data_field_carousel_slide_url. Why would the update be looking for the same table name, but with part of it repeated and appended? And is there any fix?

EDIT: So turns out there was an update for the Bootstrap Carousel module, of course. I'm new to running regular updates, so can anyone provide helpful information about what in schema.inc actually causes this behavior?

  • I have no idea, try disabling and uninstalling carousel then updating core and installing carousel after. – No Sssweat May 19 '15 at 0:25
  • What is the size of your db ? I know in your db this table might be exist but in spite of that you will getting error. – Nishant Pandya May 19 '15 at 4:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.