0

I am unable to add any field in my custom content type, when I click on save button or click on upload after adding images it gives me the following error and for the text field the error is simply Exception thrown without a stack frame in unknown on lne 0, after this a white screen appears. :
enter image description here

After this website appears to be blank until I import the database again. UPDATED After adding following lines of code in the bottom of settings.php,

error_reporting(-1);  // Have PHP complain about absolutely everything 
$conf['error_level'] = 2;  // Show all messages on your screen, 2 =   ERROR_REPORTING_DISPLAY_ALL.
ini_set('display_errors', TRUE);  // These lines just give you content on WSOD pages.
ini_set('display_startup_errors', TRUE);

I got the errors appears instead of white screen: enter image description here

  • It doesn't look like your web server is returning any data on the AJAX request for uploading. Does your Drupal logs report any PHP errors? – Shawn Conn May 20 '15 at 22:33
  • @Shawn, in recent log messages there is a php warning Warning: array_flip() [function.array-flip]: , I dont know what is this but really confused why I cant upload more than one image in my custom content type – nomeer May 21 '15 at 4:41
  • That's likely not the problem. Warnings don't completely stop page execution. – Shawn Conn May 21 '15 at 5:01
  • Actually not only image field, I am unable to add any field :( – nomeer May 21 '15 at 5:03
  • 1
    Take a look at this post to see what error that pops up after a field save crashes the site. An AJAX http request terminated abnormally error is so broad you'll never find a good answer. – Shawn Conn May 21 '15 at 5:53

Browse other questions tagged or ask your own question.