1

I am unable to upload an image from my desktop in Drupal 7. I am trying to upload an image to a blog without using Ckeditor. I have created a field for the image and assigned it as image. All looks good. The problem happens when I go to create a new blog, I see the field for the image. I click on the "Choose file". It brings me to my desktop. I select the image and then click onto "Upload". The small blue wheel begins to spin. Then I get the WSOD. I see, in Firefox, at the bottom of the page "Transfering data from XXX.com..."

  • do you get any errors in the log or browser console? – Geoff May 22 '15 at 6:00
0

If you are trying to upload some bigger images, it is possible that you are out of memory.

Processing large photos requires lots of power and memory. Set the RAM with php_value memory_limit 128M or 256M if your hosting allows.

  • My files sizes are all below 1 MB. For more clarity, it is the default upload feature which brings me to the WSOD after selecting a image. I noticed to other day, when I deleted my .htaccess file that I was able to upload images again. But I need that .htaccess file, so I reloaded the file and the problem returned. – Marc Bertrand May 23 '15 at 17:56
0

Found my answer. It was not a PHP issue but rather a JQuery issue. I did not install the JQuery module originally. Once uploaded and enabled, all of my JS, JQ, and so on,were cleaned up and updated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.