0

i have been trying all morning to get my webform to open up within ctools modal_forms popup window. i’ve tried everything, but nothing has worked so far.

the module is working no problem. this form window displays as expected.

mywebsite.com/modal_forms/nojs/register

and my webform is published and working

mywebsite.com/webform/free-trial

but when viewing docs and tuts on the module, the URL would seem to be

mywebsite.com/modal_forms/nojs/webform_free-trial

i’ve also manually created links such as this

<a class="ctools-use-modal" href="/modal_forms/nojs/webform/free-trial">Modal Login</a>

<a class="ctools-use-modal" href="/webform/free-trial">Modal Login</a>

even went to the config page and set,

PAGE ACTIVATION SETTINGS/Only the listed pages

webform/free-trial  

Mondo Aggro! any help would be greatly appreciated, thank you

2 Answers 2

0

I would recommend you to create your own menu item where you should load and print the webform using examples from the ctools module.

2

The issue is your modal link path isn't correct. When using Webforms the link needs to use the Node ID (nid), not the form clean-url (/modal_forms/nojs/webform/[nid]) Here's how the link would look considering your example above:

<a class="ctools-use-modal ctools-modal-modal-popup-large" href="/modal_forms/nojs/webform/123123">Free Trial</a>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.