2

I've got an installation of Drupal Commerce Kickstart, and I've been developing it on my LAMP stack on my computer. The admin menu's working perfectly there. I recently migrated the site to the live server (also a LAMP stack), and Admin Menu simply doesn't work. Everything else works.

Specifically, it's being displayed (unstyled) at the bottom of the page on front-end pages (Zen subtheme) and admin pages (Seven subtheme). Sometimes it doesn't even show up at the bottom (it's completely missing).

More info: The version of PHP and MySQL are recent on both sites.

I used Backup and migrate to do the DB migration, with no issues. I've also just updated to the latest core version (7.37), and that made no difference.

Strangely, every other module seems to be working fine, except Admin Menu. And I've never encountered this before on any other Drupal sites I've built.

I have a feeling it's something to do with Commerce Kickstart's interference in the Management menu.

Updates: things I've tried that didn't work:

  • I've cleared Drupal cache, browser cache, site-specific cookies.
  • changing all the Admin Menu settings.
  • uninstalling and re-installing the module.
  • using a different browser: tried Firefox and Chrome.
  • In my experience admin menu can go horribly wrong every now and then, it's usually related to CSS/JS aggregation. Fully uninstalling then reinstalling always fixes it for me – Clive May 28 '15 at 14:27
  • Unfortunately I tried that, twice to be sure, and it simply didn't fix it. I'll update my question to include this. – Dane Rossenrode May 28 '15 at 14:34
  • Any JS/request errors in the console? Something like "$.browser is undefined"? – Clive May 28 '15 at 14:37
  • Ah yes, I didn't think to check the dev tools console! Unfortunately the only errors are related to the Google webfont (which I should fix in my theme); no other js/request errors… – Dane Rossenrode May 28 '15 at 14:40
  • Yeah I've had exactly that happen to me on several sites with admin menu before. Always live, never dev. Do you have advagg installed? – Clive May 28 '15 at 14:42
1

It was a file permission problem!

It turns out that, as per Apache's and Drupal's recommendations, I had set the permissions for all folders/directorys in my sites/all/* folder to be 750, and 640 for files. So for those who don't know, that means that 'others' (people who don't 'own' the files or folders) can't access them in any way.

It seems that my web host had incorrectly not assigned Apache to the correct group so that it would be able to run using those safe permissions (I know why, and I'm going to send them an irritated email asap).

I simply used Filezilla to recursively change the permissions to 755 and 644 respectively. Not quite safe, but I can change them back later.

  • Yep, that sounds familiar :) – Clive May 28 '15 at 15:24
0

From issue nr 2322605:

This is rather a common problem, particularly if you are using the contributed admin_menu rather than the Toolbar module in core. Clearing caches may help. (If you have alternative caching such as memcache that can make a normal cache clear fail in part.) You may also check whether it works when you switch theme to a Drupal core theme.

Another potential solution is to uninstall/reinstall the Admininistration menu module (as Clive also suggested in the comment).

Exceptionally, it may also be caused by a php memory limit problem (increase the limit in that case).

  • Thanks, but clearing caches didn't solve it. And I'm not using any caching modules. Also, it doesn't work on any admin pages with the Seven (core admin) theme - with or without the overlay. – Dane Rossenrode May 28 '15 at 14:36
  • Also I can't see how it could be a PHP memory limit problem if no other modules are having a memory problem… also, both dev and live sites have 128MB of memory. – Dane Rossenrode May 28 '15 at 14:37
  • 1
    I would go so far as to say it 100% definitely isn't a memory problem. You can easily check the logs to be sure, but the symptoms described basically rule out memory overflow – Clive May 28 '15 at 14:39
0

If the admin menu has issues it could be because of the following 3 points:

  1. If you get warnings about not being able to store temporary items you may need to change the temp location. Do this on the File System settings page at admin/config/media/file-system

  2. If site appears funny – with content but not styled try deleting (they will be remade automatically)

Sites/default/files/css

Sites/default/files/js

Sites/default/files/ctools

  1. Try disabling and re-enabling the CSS and JS caching in the performance page admin/config/development/performance

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.