0

OK the site was fine until I updated the core of the website. Now the images do not show up. I have checked the paths and they are correct. I have checked the permissions and they are 777. I have an SSL on the site but as I say, it was all working well before! I've spent the last few hours trying to resolve this but to no avail. I've deleted and uploaded the core again - same. Any suggestions appreciated!

  • Do you know what version you upgraded from and to? – albertski May 29 '15 at 16:01
  • Druapl 7.36 to 7.37 – robbyutd May 29 '15 at 16:02
  • Did you have SSL before the upgrade? – albertski May 29 '15 at 16:02
  • yes, I did - so it was just the core update. – robbyutd May 29 '15 at 16:04
  • and I've done core updates before no probs ?! – robbyutd May 29 '15 at 16:04
2

It can be something wrong with File system settings. You may check it here admin/config/media/file-system

  • Public file system path sites/default/files Private file system path (empty) Temporary directory tmp – robbyutd May 29 '15 at 15:58
  • what do you get, when you open direct image url? – Andrew May 29 '15 at 16:01
  • error occured - 403 forbidden. Is that because of my ssl? – robbyutd May 29 '15 at 16:03
  • @user47898, try to change your temporary file (/tmp) to 777 for testing purpose. Usually this problem is a bad configuration with the admin/config/media/file-system. – itsdarrylnorris May 29 '15 at 16:56
  • already set to 777 :( – robbyutd May 29 '15 at 16:57
0

This might be a temporary solution but add this to settings.php:

$conf['image_allow_insecure_derivatives'] = TRUE;
  • added to foot of settings.php (sites/default/settings.php). is that the one you mean? No change. Going to delete cache again... – robbyutd May 29 '15 at 17:01
  • deleted cache - same. checked in another browser - same. – robbyutd May 29 '15 at 17:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.