5

When I attempt to enable the REST Server module, I get the following error message:

A library is missing for rest_server to work (Currently using Missing library Please download spyc and create a file called spyc.php in rest_server/lib)

The spyc.php file is included with the module in the rest_server/lib directory, but the error is still reported, and prevents the module from being enabled.

Drupal version: 6.22

Rest Server module version: 6.x-2.0-beta3

I reported the issue on the module page.

Just wondering if you see any patterns that could help me debug this issue.

7

Download spyc from http://code.google.com/p/spyc/. Inside the spyc folder find the file called spyc.php and copy it to the Services Module 'servers/rest_server/lib/' directory.

  • 3
    Thank you. I assumed the error message meant the modules/rest_server/lib/ directory. – grough Nov 24 '11 at 14:38
  • @drebables Thanks for pointing out the correct location. – Ajinkya Kulkarni Nov 28 '11 at 21:57
  • Well, I must be forgotting something. I download spyc.php from the link, I put it on servers/rest_server/lib/ but the installer still disallowing me to activate Rest server option. Permissions are OK and I already have launch update script in modules. – vgonisanz Feb 13 '13 at 15:17
0

after you put the spyc.php in the modules/services/servers/rest_server/lib folder, go the the Modules configuration, disable the REST server, then re-enable it.

That worked for me.

0

Some places you can put rpyc (download from http://code.google.com/p/spyc/downloads/detail?name=spyc-0.5.zip):

servers/rest_server/lib
modules/services/servers/rest_server/lib
profiles/<someprofiles>/modules/services/servers/rest_server/lib

Hope this help

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.