0

I created a view block. I can see the view block on my page (node/30) no problem. Edited the view by adding filter criteria. I also changed "use Ajax to Yes". I can see the exposed filter in views edit page but I dont see the views at all on my actual page when I add the filter criteria. After I remove the filter criteria, I see the views again on my page. When i added the filter criteria, I also checked "exposed to user option.." I am not sure what I did wrong.

Please help.

D

  • Try by adding nid in contextual filter. – Viraj Jun 2 '15 at 9:42
  • Experiencing the same issue in D8 Did you ever resolve this issue, learn4ever? – user1234 May 15 '18 at 22:47
1

Mb it's because there is no result. In that way you will see exposed form on edit page, but view will not be displayed on front because it's empty (so, there is no need to display exposed form for user and it's hidden).

Try to go on your view's edit page to No results behavior and make it display some text to see if view has no result

0

Please check if the 'Exposed form in Block' option under 'Exposed Form' section within the 'Advanced' accordion on the right, is set to 'Yes'.

enter image description here

If so, then your exposed filters will be under 'Disabled' in Structure > Blocks.

You will have to move that exposed form to the specified region.

enter image description here

Also check if the user who visits node/30 also has access to use the filter criteria used in the block view (That is, if you have any field permissions set).

Hope this helps.

  • I dont see block option under exposed form. i only see Exposed form Exposed form style:Basic | Settings – learn4ever Jun 3 '15 at 19:41
0

Get to the Exposed filter form section of the ADVANCED box to set Exposed form in block: to "Yes" and doing so will make the filter be displayed in the views page (if you had that in your setting).

In D8, this setting will make the form avialble in the block but not on the page. On D7 the filter will show up in both page and block but in both instance the user must have permission to use search else it will not show up at all. If after all these are done and still not showing up you need to clear cache and/or rebuild permissions!

And if the search is related to searching user information the logged in user must the "View user information" permission to see/use the search exposed filter.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.