0
  • Using Drupal 7.37, Omega4-SubTheme

  • Acquia Dev-Desktop Stack (Development)

  • Windows 7 HP

Using Media Module with the Flickr provider Module installed, the Media_YouTube, and the Media_SoundCloud providers installed as well (along with their dependencies).

  1. I set up some dummy-content via a customized Create-Content node. Added Flickr-Images as a field-type bundled with various tags to distinguish properties of my Media-Files for later categorization. I have other Media-File-Types and their Providers installed as well (Media_YouTube, Media_SoundCloud) and they work fine without adding outbound-site-leaving-links.
  2. Then I set up Views to output all the content of the website along with respective fields. All this works and displays small representations of the media in a table along with my added fields.
  3. In this Views display, Flickr embedded-images show up fine and can be styled, but unlike YouTube-Videos or SoundCloud_Audio-Files, Flickr-Embedded-Images will leave the website when clicked. Both YouTube and SoundCloud do not exhibit this behavior and instead only play their respective Media.
  4. Is there anyway to block, stop, or (best) redirect the Flickr-Images to show their associated node rather than linking to Flickr?
  5. I have tried every configuration Option I can find. I have tried options in the Create-Image-Content node GUI but I see nothing to suppress the outbound-links. I have tried the Views-Display GUI, but again, I see nothing in the Views-Settings that suppresses the outbound-links. And I have also tried the Administration>>Configuration>>Media>>File-Types setting for my Image-File-Types (this control-panel is very mysterious). In none of these locations can I come across something which shuts-off this outbound behavior.
  6. I have spent much time trying all kinds of option-permutations and searching for any kind of documentation but have come up with no solution.
  7. Is there an option-solution or a css-workaround or do I have to abandon the Flickr-provider-module because this is its hard-wired behavior?
  • as a worst case, you could add a couple lines of jQuery to create a DIV over top of the image which would prevent it acting as a link – Geoff Jun 2 '15 at 10:23
  • I decided just to strip out Flickr, Media_YouTube and Media_SoundCloud and go with Media_Oembed. One Module handles all of the Embeds without Flickr-Images out-linking. – ChandraSwami Jun 3 '15 at 5:12
0

For now I have completely disabled Flickr as well as Media_YouTube and Media_SoundCloud in favor of using the Media_Oembed Module. Media_Oembed handles the all of the above Embed needs (and more). In Media_Oembed, the Flickr Module does not out-link. Probably a better overall solution in general.

There are two OEmbeds!! At first, I tried Oembed, which is still in beta (as of 2015-06-03) and I could not get it to work; I don't know what the problem was, but Media_oEmbed seems to work fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.