8

I'm using Drupal 8.0.0-beta10. I just tried to add a new basic page node that contains an image hosted in an external website: While it's showing up in the preview, the image isn't showing up once the node is published; when I hover over the broken image, it shows the following message.

This image has been removed. For security reasons, only images from the local domain are allowed.

How do I override this?

16

First, you need to know which input text filter you have enabled where the images are not showing. For the sake of this answer, let's say it's the "Basic HTML" input filter.

Go to the configuration for this input filter, such as /admin/config/content/formats/manage/basic_html

Scroll down to "Enabled Filters" and look for:

"Restrict images to this site"
Disallows usage of tag sources that are not hosted on this site by replacing them with a placeholder image.

enter image description here

If you can not view externally-hosted images, it is likely this filter is enabled. Simply disable this filter.

1
  • I came across this when using the CDN module. Screenack has the right answer, but if you're a more visual person, here's a 90s video showing the effect and to make the fix youtube.com/watch?v=sBfB8QCtvIA
    – versantus
    Jan 22 at 6:43

Not the answer you're looking for? Browse other questions tagged or ask your own question.