I am using Open Outreach. When I create an article the image I uploaded appears on the home page, but does not appear when I click the link for that article.

From what I've read, it looks like it has something to do with Configuration/Media/File System. My public file system path is set as sites/openoutreach-7-x-1-19.dd/files. Do I need to change this? If so, what do I change it to?

Log message:

Type page not found Date Thursday, June 4, 2015 - 9:43am User admin Location http://openoutreach-7-x-1-19.dd:8083/sites/openoutreach-7-x-1-19.dd/files/styles/medium_large/public/Portulaca%20grandiflora.jpg?itok=OP-6w24x Referrer http://openoutreach-7-x-1-19.dd:8083/article/june-3-2015-newsletter Message sites/openoutreach-7-x-1-19.dd/files/styles/medium_large/public/Portulaca grandiflora.jpg Severity warning Hostname

There is no medium_large folder in my styles folder. Do I need to create one?


2 Answers 2


When contrib images are missing in drupal the cause more often than not is that you have permissions problems with regards to your filesystem.

Make sure that your webserver can write to your files and files/styles directories.

If permissions are ok then drupal will create your medium_large directory and subdirectories.

Check the drupal setup documentation here (see the paragraph "Create the files directory").
As mentioned there make sure that you have write permissions on your sites/default/files directory.

  • Comments have been removed. Please don't use them for extended discussion.
    – apaderno
    Commented Jun 8, 2015 at 5:25

I was rumaging through the module listing and found Debut Article. On the oft-chance that this might be causing problems I went to the debut article page on drupal.org and found drupal.org/node/1473574. It states that because fields are not true exportables, the resulting approach may be fragile and prone to breakage if, e.g., debut_media is not enabled prior to the article implementing the hook_alter, i.e., in this case, debut_article. I enabled debut media and it worked!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.