0

enter image description here

I added a field to content type. The field type is select list. I created a view. I added a filter criteria using the above field:

Operator > Is one of

Options > Select All is selected.

When I go to front end, I see -Any- selected by default but I dont the content/result. When I click Apply, i get the result. I am not sure why I have to click Apply to get the result. It should give me result as soon I go to views page.

Please help.

  • thats weird, you shouldn't need to hit the apply button. Try creating a new view and see what happens. – No Sssweat Jun 5 '15 at 0:03
2

I just tested this and got the same problem as you.

I found the solution you need to check mark limit to selected items.

If you don't have the Limit list option, check marking the expose operator also fixes it. You would then have to use css to hide the expose operator if you don't want it.

enter image description here

| improve this answer | |
  • I have created new view, created new content type and field. I still have the same problem. I just saw your answer and it solved it. I just had to place the check mark to the selected items. I have created this kind of view before, I don't think I had this kind of issue before. Thanks a lot. – learn4ever Jun 7 '15 at 1:01
  • @Drupol yeah seems the issue is with content type filtering. When using fields as a filter, it doesn't happen. – No Sssweat Jun 7 '15 at 1:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.