0

I have a view, and the key display points are:

  • Format: Unformatted List (I'm adjusting the views look through CSS)
  • Show: Fields

One of the fields to show is Body (so, a textarea.) When I choose to display it as "Summary or Trimmed", and set the trim length to, say, 600, it trims it fine, but it doesn't show a "Read More" link to the content's page. Is there something I'm missing?

1

did you check " Add a read-more link if output is trimmed. "?

If yes, maybe the problem is, that the text is not trimmed. If you want to have a "read more" link in any case, then you sould add the field "Link" to the view. You can then also enter your custom text, e.g. "details..." instead of "read more" etc.

| improve this answer | |
  • The problem is I'm not seeing that option; I've got "create a lable", "exclude from display" and "Formatter". If I choose "Trimmed" or "Summary or Trimmed" from "Formatter", the "Trim Length" field appears... but that's my only new option. – UnsettlingTrend Jun 5 '15 at 15:26
  • Nevermind. Found it. It wasn't where I was expecting. It was under "Rewrite Results". Thank you! – UnsettlingTrend Jun 5 '15 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.