5

I got a panel and added a comment form for this certain node type but the comment form does not show up.

  • I have enabled commenting for this content type and appropriate permissions (can post comment) for any authenticated user.
  • I tried disabling the panel for node templates.

In both case the comment form still does not show up. What could be wrong?

14

If you have changed the content type to allow for commenting, it does not back-propagate to existing nodes. So, check to see the individual comment settings on each of nodes that it does not appear on to make sure they are indeed enabled.

  • 3
    got it! thanks heaps. Never crossed my mind. Makes sense to not back-propagate. That I missed 100% :D – jan Nov 25 '11 at 5:50
  • +1 upvote answer, +1 upvote comment. Helped me too. For me, the other thing I had to do was, with display suite, in the field manage display tab of the content type settings, ensure that the comments region is visible -- set to appear in one of the regions displayed using display suite. Of course, this wouldn't apply to you if you are not using the display suite module. But hope it helps anyone who is. Once again, cheers! – therobyouknow Sep 3 '13 at 14:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.