0

When I expose the country field from the address-field module as a selective exposed filter (to only show countries that are in the results of the view), the "selection" works, which means only the appropriate countries are shown in the dropdown of the filter. But after clicking "Apply" the results are zero.

I have tried to rewrite the field but to no avail. I think the problem is, that the country is taken from the core. If i try other fields from the address field, it works.

Any help appreciated! Thanks!

EDIT: I just found out about the checkbox on the field itself called: "Display the localized country name instead of the two character country code". If this is unchecked, the view and the filter are working. But now i have a unreadable list of country abbreviations in my dropdown.

Is there something i can do about this?

0

I found a workaround on this. In the content-type with the address field i created a new field with a token of the country-field that is now working like a charm with views-selective-filters.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.