1

I have a custom drush make file and custom drupal installation file for a new site. Both work fine on my local VM, and the local VM's of the three other developers who have tried it. However, when I try to run it on our test server, it chokes:

sudo drush -y make stub.make
Make new site in the current directory? (y/n): y
Beginning to build stub.make.                                       [ok]
drupal-7.37 downloaded.                                             [ok]
drupal patched with 1093420-22.patch.                               [ok]
drupal patched with comment-node-type-delete-1565892-3.patch.       [ok]
Generated PATCHES.txt file for drupal                               [ok]
MYPROFILE cloned from git://github.com/MYPROFILE.                   [ok]
Checked out branch development.                                     [ok]
Found makefile: MYPROFILE.make                                      [ok]
Aborting.

The first time this error occurred, my investigation uncovered a permissions issue. However, that is fixed, and I'm still getting the error.

The MYPROFILE.make begins with:

api = 2
core = 7.37

And continues with a bunch of

project[MODULE_NAME][subdir] = contrib

As well as

projects[CUSTOM_MODULE][type] = module
projects[CUSTOM_MODULE][download][type] = git
projects[CUSTOM_MODULE][download][url] = git://github.com/CUSTOM_MODULE
projects[CUSTOM_MODULE][download][branch] = development
projects[CUSTOM_MODULE][download[branch][working-copy] = TRUE

projects[CUSTOM_THEME][type] = theme
projects[CUSTOM_THEME][download][type] = git
projects[CUSTOM_THEME][download][url] = git://github.com/CUSTOM_THEME
projects[CUSTOM_THEME][download][branch] = development
projects[CUSTOM_THEME][download][working-copy] = TRUE

Everything works fine on the Vagrant for Drupal Development box downloadable from Drupal.org, and also on a custom Vagrant box another of the developers set up that integrates better with components beyond the website. But on the dev server, it chokes without giving a reason why. Googling for drush make found makefile aborted didn't turn up anything.

Is there some sort of diagnostic tool that I can use to get a more helpful message than 'Aborting'?

Forgot to add:

Before posting this, I tried running drush make directly on the MYPROFILE.make:

sudo drush -y make profiles/MYPROFILE/MYPROFILE.make
Make new site in the current directory? (y/n): y
Beginning to build profiles/MYPROFILE/MYPROFILE.make.              [ok]
No core project specified.                                           [error]

But as you can see from my excerpt of the make file above, it does specify a core. And again, it works on two different VMs. -- Since MYPROFILE.make was designed to be called by stub.make, the above error is the expected reaction when running it alone.

2 Answers 2

1

Have you tried this recently? It's hard to tell from the info you posted above, but your problem could very well have been caused by the ssl certificate problem on updates.drupal.org. Since sometime yesterday until a few hours ago, https connections to updates.drupal.org were failing due to a limitation of the new CDN they are using now. This caused drush dl and drush make to fail. (n.b. Drush caches update information, so things likely continued to work from the cache on systems that were working before the cert problem started.)

The drupal.org team has things patched up now, so try doing everything again from the beginning, and see if it starts working again. If that does not clear up the problem, try running drush make again with the --debug option, and post the results.

1
  • Don't know how I forgot about --debug; that's what I get for writing up a question at the end of a long day, rather than waiting for morning! Jun 11, 2015 at 10:45
1

The reason the Make file was failing was because one Contrib module that I was downloading no longer had a "recommended release" for 7.x. Fortunately, that module was non-essential, and removing it fixed the problem. (Had it been essential, the solution would have been to request the specific version, rather than defaulting to the latest recommended release, which is good practice anyway.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.