1

I want to create a sub-theme with Omega using drush but I get a couple of errors. I've been trying to solve these problems for a bit now and I need some help. I'm using OS X and XAMPP as my local web server.

When I change directories into my site:

/Applications/XAMPP/htdocs/joshvocal/sites/all/themes

and run drush omega-wizard I get these errors:

The drush command 'omega-wizard' could not be found. Run drush cache-clear drush to clear the commandfile cache if you[error]have installed new extensions. Drush was not able to start (bootstrap) the Drupal database.
Hint: This may occur when Drush is trying to: * bootstrap a site that has not been installed or does not have a configured database. In this case you can select another site with a working database setup by specifying the URI to use with the --uri parameter on the command line. See drush topic docs-aliases for details. * connect the database through a socket. The socket file may be wrong or the php-cli may have no access to it in a jailed shell. See http://drupal.org/node/1428638 for details.

I think the problem has something with drush not being able to connect to my database.

I've tried:

  • Changing my settings.php file from host: localhost to host: 127.0.0.1
  • Creating a symbolic link with /Applications/XAMPP/xamppfiles/var/mysql/mysql.sock /var/mysql.sock

When I run my drush status this is what is looks like:

My drush status

I think this is what it should somewhat look like:

What I think drush status should look like

I want to know how to fix these errors and be able to run drush omega-wizard to create a sub-theme on omega.

Thank you for your time,

Josh

  • Is the site accessible? After downloading the omega theme have you cleared your cache? Also try doing "drush owiz" to start creating your subtheme. – Leolando Tan Jun 13 '15 at 2:22
  • Yes, the site is accessible through localhost on my computer. I've tried clearing the cache with drush cc drush and drush cc. I also cleared the cache on the website in performance, it didn't work. drush owizgives me the same errors as the first picture above. – Josh Jun 13 '15 at 3:08
  • Since at the moment you're using Drupal 7, could you try using Drush 6? You're using composer to install Drush? – Leolando Tan Jun 13 '15 at 3:25
  • I could try using Drupal 6, but I prefer moving forward and using the most current stable version. Yeah, I'm using composer to install Drush. I've followed these youtube tutorials: How To Install Drush on OSX and Installing Drush on Mac OS X with Composer – Josh Jun 13 '15 at 3:37
  • I understand too but I just want to narrow down the possibilities of error then we could move to other possible causes maybe? What are your thoughts on this? – Leolando Tan Jun 13 '15 at 3:39
3

Add -d option so that command looks drush -d omega-wizard. You will see debugging information showing what causes problems.

  • great it works for me thank but i can not understand why we use -d before omega-wizard Please justify thank you in advance – Deepak Singh Aug 2 '16 at 12:13
  • This really should be a comment, not an answer. – UltraBob Aug 2 '16 at 12:35
  • and the -d flag adds debugging output. – UltraBob Aug 2 '16 at 12:36
0

I had this issue, turns out I didn't have the MySQL bin directory in my system path.

This question appears quite high up Google, so for anyone else reading this having the same issue...

Go to Control Panel » System » Advanced » Environment Variables, double click on Path under System variables, click New and add the path to your MySQL bin directory.

In my case this was H:\wamp64\bin\mysql\mysql5.7.11\bin, but it will depend on the location of your WAMP installation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.