1

I am creating a content type that contains a field of type "Entity/user reference", and for the widget I want the user to be able to select multiple entities.

I installed and tried the Improved Multi Select module, however I did not find it in the widgets list.

Then I installed and tried the Multiple Selects module, I found it in the widgets list, however it does not work the way it should: it works like a normal select list that allows selecting one entity, it is not giving me the option to "add another item".

How can I fix this? Or does anyone know another way for allowing multiple selection?

0

From the various attempts you tried, it seems that the reason for your issue is simply that you have not indicated that "multiple values are allow" for this field.

To ensure multiple values are allowed, navigate to /admin/structure/types/manage/mytype/fields/field_abc (assuming 'mytype' is the machine name of your content type, and 'abc' is the machine name of your field). As an alternative, use the "edit" link for your field, within the "manage fields" tab for your content type, after you selected the content type via Admin > Structure > Content Types.

Then within the option that says "Number of values", indicate the "Maximum number of values users can enter for this field.". Note: the default is 1, so if you did not change that yet (eg to 'unlimited'?), then that would explain your issue (and resolve it).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.