0

I have a Multilingual Drupal 7 website. using i18. I redirect my visitors based on IP address with IP to locale module. Now e.g. visitors from Holland (Dutch IP) are redirected to http://landberg.at/nl

But now I am not able to select another language, with my language switcher? E.g an English person who lives in Holland must be able to switch to the English version. http://landberg.at/en

How do I have to achieve this? Is this anyway possible with language redirect based on IP?

(currently on my site I switched IP 2 locale OFF)

2
  • Is this for D6 or D7? Consider editing your question to clarify that ... Jun 17, 2015 at 13:22
  • A Drupal 7 website.
    – Meez
    Jun 17, 2015 at 13:29

2 Answers 2

0

You have tried Language Switcher module but you are not getting any result. Once try to use Language Switcher Dropdown module.

Language Switcher Dropdown is a very simple module that exposes a new block, similar to the default Language Switcher block provided by Locale module. The new block allows site visitors to switch languages using a drop-down select list instead of using hyperlinks.

3
  • i just tested it but it doesn't make a difference. Still after redirect your not able to switch language. You can test it here.
    – Meez
    Jun 17, 2015 at 11:15
  • I have just check, Default English is showing. When I click on German, it redirect to English but when I select Dutch it redirect to Nederland & page url is change to 'landberg.at/nl'. I think your language selection configuration inside Configuration -> Languages -> detection and selection is wrong. Please check.
    – Nishant
    Jun 17, 2015 at 13:09
  • Thanks i have now inside Configuration -> Languages -> detection and selection: -URL -Standaard But if i enable: -URL -User -Standaard I get in my browser an error: ERR_TOO_MANY_REDIRECTS –
    – Meez
    Jun 17, 2015 at 13:16
0

Consider a special patch

Your issue seems fairly similar to what is described in Patch for language switcher to override ip2locale. It is for D6 though (not sure what this question is for D6 or D7 ... I think D7). Not sure if you want to consider exprimenting with the patch attached to it (attention: status of the issue is "needs review").

Check language detection

It seems to me that you should check your configuration at Configuration -> Languages -> detection and selection: the order specified there could be what explains the current behaviour in your site.

You'd have to experiment a bit with what the exact order in your case should be. In my experience, I often get these kind of issues to work by using an order like 'URL, Default, User', and not something like 'Default, URL, User'. It could well be that that is all that's needed here ... So try to experiment a bit with the various combinations in this order to see if it helps.

Curious to hear what the result of checking this will be ...

1
  • Thanks i have now: -URL -Standaard But if i enable: -URL -User -Standaard I get in my browser an error: ERR_TOO_MANY_REDIRECTS
    – Meez
    Jun 17, 2015 at 13:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.