1

I have a content type topic, and a Webfrom "contact" as block which is available for topic content type only.

Any registered user can create topic, and I want to use the Webfrom to contact the topic author.

In the past I had a hidden field inside Webfrom with a token [current-page:node:author:mail] to send the Webform information to the current page author email "topic author".

After updating the Webfrom to version 7.x-4.9 the Webfrom stop sending email.

It looks like [current-page:node:author:mail] is not available any more.

I will be grateful if someone help me with identifying the right token to access the current page author mail. or suggest alternative way to achieve the same functionality.

Thanks

2

After almost 4 weeks driving us crazy , we have finally found where is the problem. Thing is we were looking in the wrong direction.

Overwrite http://s000.tinyupload.com/?file_id=06809135818916665525 after updating Token to 1.6. Just extract it on sites/all/modules/token. We don't know why yet. We have completely checked all the change logs, git commits and everything in Webform and finally decided to look in another direction.

You can update the Webform module as suggested by the module maintainers.

So, to have it back working, do the following:

  1. Upgrade to Token 7.x -1.6 http://ftp.drupal.org/files/projects/token-7.x-1.6.tar.gz
  2. Extract the file http://s000.tinyupload.com/?file_id=06809135818916665525
  3. Clear the cache

The token will be back.

We have obtained all the feedback from this post https://www.drupal.org/node/919760 and the patch applied is https://www.drupal.org/files/issues/token-current_page_object_token-9197.

1

In order to make token [current-page:node:author:mail] working again, you need to apply this patch for Token module.

Source.

0

If You click email tab in webform,there is token option available. In that we can choose what we needed. I think,this option is suitable for your problem.

[current-user:mail]

  • 1
    thanks for reply, token [current-user:mail] is not any option because anonymous will submit the form. – Yama Jun 25 '15 at 11:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.