0

I installed the module Drupal For Facebook. So far it was working perfectly, I enabled Facebook Connect and put the Facebook Connect login block in a sidebar. It was great until I went into configure the Facebook Connect login block and changed text in the body. Now the CONNECT button no longer appears and only text appears saying the words "Connect." I've tried every mix of plain text, full html, and filtered html to include the suggested enter of: Connect to no avail. The only thing I see is the word Connect in plain text every time.

I need to reset this module to default or learn how to properly add the button back. But I am very new to Drupal and have no idea how to do it.

  • have you tried removing the changes you made? – karthik Nov 28 '11 at 14:03
  • I have removed everything I added, which leaves the field blank and thus renders the block null. I then added (in plain text view but utilizing full html) what the module suggests (<fb:login-button scope="!perms" v="2">Connect</fb:login-button>) which simply leaves the word Connect on the page with no link or button. – Justin Smith Nov 28 '11 at 21:55
  • Basically what I did to begin with was this: I installed the module, enabled and placed the FB Connect block, went in to configure it and because I use a WYSIWYG CKEditor all I saw in the field was the word Connect, which I edited to say Login Using Facebook, when I did so the button disappeared and came back on the site as simply text. I messed something up but I am not sure how/what. – Justin Smith Nov 28 '11 at 21:57
  • this might probably be an issue with the module. post it in the module's issues on drupal.org . – karthik Nov 29 '11 at 2:19
  • I have the same issue. ... Your issue is not in the format - I looked in admin/configuration/fbconnect - in the 4th tab it says that I am not connected to the FB App. ..... Checked the API Key and the API Secret they are correct. If you google it there are some suggestions that you should just create another app, ,,, FB has another key - an auth key separate from the API and secret and I think that is where all this problem is coming from. I do not want to create new app because my FB app page is all setup. – Paulo Mar 4 '14 at 22:45
1

I have the same issue, FB Connect will do this when your site tries to connect to an FB App and cannot. Check your API and Secret keys first, other possible problems are the URL settings which should match in both FB and Drupal/FBConnect. Lastly in my case, everything was working until I reset an auth key in FB which I should not have done and it created issues for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.