1

I'm getting the below Fatal Error after I uninstalled the Views Chart Tools and the Google Chart Tools modules.

Fatal error: views_plugin_display::destroy(): The script tried to execute a method or access a property of an incomplete object. Please ensure that the class definition "views_chart_tools_plugin_display_dashboard" of the object you are trying to operate on was loaded before unserialize() gets called or provide a __autoload() function to load the class definition in /home/XXXX/XXXX/sites/all/modules/views/plugins/views_plugin_display.inc on line 272

I was working with them but they did not serve my purpose. After uninstalling them I started getting the above error.

I can't clear cache or even view the block admin page. Can anyone tell me what I can do to resolve this?

  • Have you erally uninstalled them? Or only disabled and then deleted their files? In other words, have you been on "uninstall" tab on modules page and performed their uninstall actions? – Mołot Jun 18 '15 at 14:32
  • Yes, I went to the uninstall tab and ran the process to uninstall after disabling. I haven't removed the directories from the server, but I don't think that would cause this. THanks for your reply – billy_comic Jun 18 '15 at 15:19
  • Welcome to Drupal Answers! This is a Q&A site, and answers are kept separated from the question. If you have an answer, write it as answer. – kiamlaluno Jun 18 '15 at 20:19
0

I would use Drush to clear the cache. If the cache still will not clear, do a registry rebuild.

If after all that you still have the error, use Drush to enable, disable and uninstall the module again. Sometimes a full cycle can clean up gremlins like this.

  • I have completely removed the modules (Views Chart Tools + Google Chart Tools) front the server. I had to use the browser solution as I'm having issues getting Drush installed. Still to no avail. I still get the error after the rebuild returns DRUPAL_ROOT is /home/music2015/public_html. Bootstrapping to DRUPAL_BOOTSTRAP_SESSION Bootstrap caches have been cleared in DRUPAL_BOOTSTRAP_SESSION Doing registry_rebuild() in DRUPAL_BOOTSTRAP_SESSION Bootstrapping to DRUPAL_BOOTSTRAP_FULL Rebuilding registry via registry_rebuild_cc_all in DRUPAL_BOOTSTRAP_FULL – billy_comic Jun 18 '15 at 16:36
  • Is there a way to completely flush via phpMyadmin? – billy_comic Jun 18 '15 at 16:39
  • Have you tried the re-install, re-uninstall cycle? – fullerja Jun 18 '15 at 17:50
  • I had not, but I flushed all caches using phpMyadmin and it cleared the error. I will be installing Drush so I don't have to hunt down cpanel login creds in the future. Many thanks! – billy_comic Jun 18 '15 at 19:54
1

SOLVED - Used phpMyadmin and selected all cache tables then using the Empty option from the dropdown performed TRUNCATE on all cache fields. At this point cleared the cache that was throwing the error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.