1

I am new to Drupal. I am reading a book called Definitive Guide to Drupal 7. I had installed Drush on Windows 7 with Git as well. It was working last week. Since 7.38 is released I tried to update my localhost website for this particular book and I am getting an error. I have googled this problem and I am coming up with some solutions but they are not working for me. I have navigated to the root folder of the Drupal installation in Git before using Drush Up. I have also changed the 'host' value in settings.php to '127.0.0.1'. It was 'localhost' before. I don't know how to fix this. Does anyone know?

Anthony@ANTHONY-PC ~
$ cd c:/wamp/www/definitiveguided7

Anthony@ANTHONY-PC /c/wamp/www/definitiveguided7 (master)
$ drush up
Command pm-update needs a higher bootstrap level to run - you will       [error]

need to invoke drush from a more functional Drupal environment to run
this command.
The drush command 'up' could not be executed.                            [error]

Drush was not able to start (bootstrap) the Drupal database.             [error]

Hint: This may occur when Drush is trying to:
 * bootstrap a site that has not been installed or does not have a
configured database. In this case you can select another site with a
working database setup by specifying the URI to use with the --uri
parameter on the command line. See `drush topic docs-aliases` for
details.
 * connect the database through a socket. The socket file may be
wrong or the php-cli may have no access to it in a jailed shell. See
http://drupal.org/node/1428638 for details.

Drush was attempting to connect to:
 Drupal version         :  7.37
 Site URI               :  http://default
 Database driver        :  mysql
 Database hostname      :  127.0.0.1
 Database port          :
 Database username      :  root
 Database name          :  definitiveguided7
 PHP executable         :  php
 PHP configuration      :  C:\wamp\bin\php\php5.5.12\php.ini
 PHP OS                 :  WINNT
 Drush script           :  C:\Users\Anthony\AppData\Roaming\Compose
                       r\vendor\drush\drush\drush.php
 Drush version          :  8.0-dev
 Drush temp directory   :  C:/Users/Anthony/AppData/Local/Temp
 Drush configuration    :
 Drush alias files      :
 Drupal root            :  C:\wamp\www\DefinitiveGuideD7
 Site path              :  sites/default
0

Make sure your Drush commands are issued from the appropriate subdirectory of your website (change to the directory where your Drupal site is installed and try again).

So try navigating to the sites/default folder (assuming this is NOT a multi-site, is it?), and then retry your Drush comand ... Seems that is what is causing your problem ...

If that doesn't help, it could well be an issue with the version of Drush that you are using. Would it be an option to downgrade to a lower version of Drush? FYI: Drush 6.x does support D7 also ...

0

I got it working. I was able to update my local website to version 7.38. I did delete my drush directory and unzipped the download into a new directory and then I re-typed the environment variables. This time I used the "Copy address" command in the search browser to copy and paste the locations into the environment variables values so I didn't have any errors. Its working now. Thanks helping Pierre.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.