0

Hi all and I apologize in advance for what seems like a rudimentary question.

I have a drupal commerce site (drupal 7.38, commerce 7.1.11, Commerce Feeds 7.1.3) and I have a very basic flag set on my custom products. The issue is I have is that I cannot seem to be able to add the flagging fields to the products displays generated from the templates imported with commerce feeds. I use a template very similar to the attribute/taxonomy terms I import via feeds. The problem is that there doesn't seem to be an obvious way to do this through the UI when editing the Content Type for my custom product display.

I can confirm that there is a flag field listed for the custom product type, but it doesn't show up in the fields available in either the Manage Fields or Manage Display tabs of my product display. The field is visible in the Manage Display tab of the product type, but is not in the manage fields list and isn't obviously manageable in some other way.

Is this commerce feeds that's tying my hands, or how do I edit these?

  • Is the issue that Product Type flags are not showing up on the display Content Type? (your title suggests otherwise). If so, you may need a bridge module: Commerce Product Reference Flag drupal.org/project/commerce_product_reference_flag – keva Jun 19 '15 at 16:33
  • thanks, that looks like exactly what I need. Should have figured, since I had to hack flag-entity-ops to get the flags into search facets – nizz0k Jun 19 '15 at 18:36
0

As pointed out in the comments, this was resolved by using commerce reference flag and adjusting my flag and displays.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.